当前位置: 主页 > 股票公式 >

终极买点选股公式

: 时间:2021-02-23 14:46

选股公式源码


SM1:=MA((2*C+H+L)/4,5);
SM2:=SM1*(200-102)/100;
SM3:=(1-7/100)*DMA(C,ABS((2*C+H+L)/4-MA(C,20))/MA(C,20));
SM4:=(C-LLV(L,9))/(HHV(H,9)-LLV(L,9))*100;
SM5:=3*SMA(SM4,3,1)-2*SMA(SMA(SM4,3,1),3,1);
SM6:=((H+L+C)/3-MA((H+L+C)/3,14))/(0.015*AVEDEV((H+L+C)/3,14));
SM7:=SM2REF(SM5,1)AND REF(SM5,1)REF(SM6,1);
买点1:=SM7;
VAR1:=REF(CLOSE,1);
VAR2:=SMA(MAX(CLOSE-VAR1,0),7,1)/SMA(ABS(CLOSE-VAR1),7,1)*100;
买点2:=FILTER(REF(VAR2,1)<20 AND VAR2>REF(VAR2,1),5);
终极买点:买点1 AND 买点2,COLORRED,LINETHICK2;

选股公式翻译


SM1赋值:(2*收盘价+最高价+最低价)/4的5日简单移动平均
SM2赋值:SM1*(200-102)/100
SM3赋值:(1-7/100)*以(2*收盘价+最高价+最低价)/4-收盘价的20日简单移动平均的绝对值/收盘价的20日简单移动平均为权重收盘价的动态移动平均
SM4赋值:(收盘价-9日内最低价的最低值)/(9日内最高价的最高值-9日内最低价的最低值)*100
SM5赋值:3*SM4的3日[1日权重]移动平均-2*SM4的3日[1日权重]移动平均的3日[1日权重]移动平均
SM6赋值:((最高价+最低价+收盘价)/3-(最高价+最低价+收盘价)/3的14日简单移动平均)/(0.015*(最高价+最低价+收盘价)/3的14日平均绝对偏差)
SM7赋值:SM21日前的SM5AND 1日前的SM5<2日前的SM5AND SM6<-100 AND SM6>1日前的SM6
买点1赋值:SM7
VAR1赋值:1日前的收盘价
VAR2赋值:收盘价-VAR1和0的较大值的7日[1日权重]移动平均/收盘价-VAR1的绝对值的7日[1日权重]移动平均*100
买点2赋值:1日前的VAR2<20ANDVAR2>1日前的VAR2的5日过滤
输出终极买点:买点1 AND 买点2,画红色,线宽为2