当前位置: 主页 > 股票学习 >

涨停敢死队选股公式

: 时间:2021-02-23 14:46

选股公式源码


X_1:=MA(CLOSE,5);
X_2:=MA(CLOSE,10);
X_3:=MA(CLOSE,20);
X_4:=MA(CLOSE,60);
X_5:=MA(CLOSE,120);
X_6:=3;
X_7:=5;
X_8:=8;
X_9:=13;
X_10:=21;
X_11:=34;
X_12:=14;
X_13:=EMA(CLOSE,X_8)-EMA(CLOSE,X_9);
X_14:=EMA(X_13,X_7);
X_15:=X_13>X_14;
X_16:=X_13X_17:=IF(X_13>X_14,1,0);
X_18:=(CLOSE-LLV(LOW,X_8))/(HHV(HIGH,X_8)-LLV(LOW,X_8))*100;
X_19:=SMA(X_18,X_6,1);
X_20:=SMA(X_19,X_6,1);
X_21:=X_19>X_20;
X_22:=X_19X_23:=IF(X_19>X_20,1,0);
X_24:=REF(CLOSE,1);
X_25:=SMA(MAX(CLOSE-X_24,0),X_7,1)/SMA(ABS(CLOSE-X_24),X_7,1)*100;
X_26:=SMA(MAX(CLOSE-X_24,0),X_9,1)/SMA(ABS(CLOSE-X_24),X_9,1)*100;
X_27:=X_25>X_26;
X_28:=X_25X_29:=IF(X_25>X_26,1,0);
X_30:=(-HHV(HIGH,X_9)-CLOSE)/(HHV(HIGH,X_9)-LLV(LOW,X_9))*100;
X_31:=SMA(X_30,X_6,1);
X_32:=SMA(X_31,X_6,1);
X_33:=X_31>X_32;
X_34:=X_31X_35:=IF(X_31>X_32,1,0);
X_36:=(MA(CLOSE,X_6)+MA(CLOSE,X_7)+MA(CLOSE,X_8)+MA(CLOSE,X_9))/4;
X_37:=CLOSE>X_36;
X_38:=CLOSEX_39:=IF(CLOSE>X_36,1,0);
X_40:=CLOSE-REF(CLOSE,1);
X_41:=100*EMA(EMA(X_40,X_7),X_6)/EMA(EMA(ABS(X_40),X_7),X_6);
X_42:=100*EMA(EMA(X_40,X_9),X_8)/EMA(EMA(ABS(X_40),X_9),X_8);
X_43:=X_41>X_42;
X_44:=X_41X_45:=IF(X_41>X_42,1,0);
X_46:=(HIGH+LOW+CLOSE)/3;
X_47:=(X_46-MA(X_46,X_12))/(0.015*AVEDEV(X_46,X_12));
X_48:=X_47>REF(X_47,1) AND X_47>(-60);
X_49:=X_47X_50:=IF(X_47>REF(X_47,1),1,0);
X_51:=(CLOSE-MA(CLOSE,X_7))/MA(CLOSE,X_7);
X_52:=X_51-REF(X_51,16);
X_53:=SMA(X_52,76,1);
X_54:=MA(X_53,5);
X_55:=X_53>X_54;
X_56:=X_53X_57:=IF(X_53>X_54,1,0);
X_58:=3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)-2*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1);
X_59:=LLV(X_58,3);
X_60:=MA(X_58,12);
X_61:=CROSS(X_58,X_60);
X_62:=MA(X_58,5);
X_63:=CROSS(X_62,X_58) AND X_62>80;
X_64:=X_58>X_60;
X_65:=X_58X_66:=IF(X_58>X_60,1,0);
X_67:=CLOSE-REF(CLOSE,1);
X_68:=100*EMA(EMA(X_67,X_8),X_8)/EMA(EMA(ABS(X_67),X_8),X_8);
X_69:=MA(X_68,5);
X_70:=X_68>X_69;
X_71:=X_68X_72:=IF(X_68>X_69,1,0);
X_73:=DMA((HIGH+LOW+CLOSE*2)/4,0.9);
X_74:=REF(EMA(X_73,3),1);
X_75:=VOL/((HIGH-LOW)*2-ABS(CLOSE-OPEN));
X_76:=IF(CLOSE>OPEN,X_75*(HIGH-LOW),IF(CLOSEOPEN,0-X_75*(HIGH-CLOSE+OPEN-LOW),IF(CLOSEX_77:=X_76/20/1.15;
X_78:=X_77*0.55+REF(X_77,1)*0.33+REF(X_77,2)*0.22;
X_79:=EMA(X_78,8);
X_80:=EMA(X_78,3);
X_81:=X_80;
X_82:=X_81>0;
X_83:=X_81<0;
X_84:=IF(X_81>0,1,0);
X_85:=IF(CLOSE>SAR(4,2,20),1,0);
X_86:=LLV(LOW,9);
X_87:=HHV(HIGH,9);
X_88:=EMA((CLOSE-X_86)/(X_87-X_86)*100,3);
X_89:=EMA(X_88,3);
X_90:=MA(X_19,3);
X_91:=IF(X_89>X_90,1,0);
X_92:=(CLOSE+HIGH+LOW+OPEN)/4;
X_93:=SUMBARS(VOL,CAPITAL);