当前位置: 主页 > 股票公式 >

太平洋底选股公式

: 时间:2021-02-23 14:47

选股公式源码


HJ_2:=1;
HJ_3:=CLOSE/MA(CLOSE,40)*100<78;
HJ_4:=CLOSE/MA(CLOSE,60)*100<74;
HJ_5:=HIGH>LOW*1.051;
HJ_6:=HJ_5 AND COUNT(HJ_5,5)>1;
HJ_7:=IF(HJ_6 AND (HJ_3 OR HJ_4),2,0);
HJ_8:=CLOSE/REF(CLOSE,25)<=1.1;
HJ_9:=SMA(MAX(CLOSE-REF(CLOSE,2),0),7,1)/SMA(ABS(CLOSE-REF(CLOSE,2)),7,1)*100<15;
HJ_10:=(CLOSE-LLV(LOW,8))/(HHV(HIGH,8)-LLV(LOW,8))*100;
HJ_11:=SMA(HJ_10,2,1);
HJ_12:=SMA(HJ_11,2,1);
HJ_13:=IF(HJ_11>REF(HJ_11,1) AND REF(HJ_11,1)HJ_14:=LLV(LOW,4)=LLV(LOW,120);
HJ_15:=(CLOSE-MA(CLOSE,58))/MA(CLOSE,58)<(-0.07);
HJ_16:=(INDEXC-HHV(INDEXC,8))/HHV(INDEXC,8)<(-0.05) AND MA(INDEXA,125)/MA(INDEXV,125)/(MA(INDEXA,5)/MA(INDEXV,5))>1.12;
HJ_17:=BARSLAST(HJ_16)<10;
HJ_18:=MA(CLOSE,27);
HJ_19:=(CLOSE-HJ_18)/HJ_18*100;
HJ_20:=MA(HJ_19,2);
HJ_21:=BARSLAST(CROSS((-10),HJ_20)=1);
HJ_22:=HJ_20<(-10) AND HJ_21>3;
HJ_23:=ABS(IF(HJ_22,HJ_20,0));
HJ_24:=HJ_23>0;
HJ_25:=MA(CLOSE,80)-MA(CLOSE,13)/3;
HJ_26:=MA((CLOSE-HJ_25)/HJ_25,1);
HJ_27:=EMA(HJ_26,12)*0.5;
HJ_28:=EMA(HJ_26,3);
HJ_29:=ABS(IF(LLV(HJ_28-HJ_27,12)>0,0,1));
HJ_30:=CLOSE/(EMA(EMA((CLOSE+LOW+HIGH)/3,3),26)*0.9)<0.95;
HJ_31:=MA((CLOSE-MA(CLOSE,21))/MA(CLOSE,21),3)*100;
HJ_32:=HJ_31<(-15);
HJ_33:=(CLOSE-MA(CLOSE,28))/MA(CLOSE,28)*100<(-23);
HJ_34:=HJ_8 AND HJ_7 AND HJ_9 AND HJ_13;
XG:HJ_34;

选股公式翻译


HJ_2赋值:1
HJ_3赋值:收盘价/收盘价的40日简单移动平均*100<78
HJ_4赋值:收盘价/收盘价的60日简单移动平均*100<74
HJ_5赋值:最高价>最低价*1.051
HJ_6赋值:HJ_5 AND 统计5日中满足HJ_5的天数>1
HJ_7赋值:如果HJ_6AND(HJ_3ORHJ_4),返回2,否则返回0
HJ_8赋值:收盘价/25日前的收盘价<=1.1
HJ_9赋值:收盘价-2日前的收盘价和0的较大值的7日[1日权重]移动平均/收盘价-2日前的收盘价的绝对值的7日[1日权重]移动平均*100<15
HJ_10赋值:(收盘价-8日内最低价的最低值)/(8日内最高价的最高值-8日内最低价的最低值)*100
HJ_11赋值:HJ_10的2日[1日权重]移动平均
HJ_12赋值:HJ_11的2日[1日权重]移动平均
HJ_13赋值:如果HJ_11>1日前的HJ_11ANDREF(HJ_11,1)<2日前的HJ_11ANDHJ_11<23,返回1.5,否则返回0
HJ_14赋值:4日内最低价的最低值=120日内最低价的最低值
HJ_15赋值:(收盘价-收盘价的58日简单移动平均)/收盘价的58日简单移动平均<(-0.07)
HJ_16赋值:(大盘的收盘价-8日内大盘的收盘价的最高值)/8日内大盘的收盘价的最高值<(-0.05) AND 大盘的成交额的125日简单移动平均/大盘的成交量的125日简单移动平均/(大盘的成交额的5日简单移动平均/大盘的成交量的5日简单移动平均)>1.12
HJ_17赋值:上次HJ_16距今天数<10
HJ_18赋值:收盘价的27日简单移动平均
HJ_19赋值:(收盘价-HJ_18)/HJ_18*100
HJ_20赋值:HJ_19的2日简单移动平均
HJ_21赋值:上次(-10)上穿HJ_20=1距今天数
HJ_22赋值:HJ_20