当前位置: 主页 > 股票学习 >

狙击强牛选股公式

: 时间:2021-02-23 14:47

选股公式源码


MA5:=MA(CLOSE,5);
MA10:=MA(CLOSE,10);
MA20:=MA(CLOSE,20);
MA30:=MA(CLOSE,30);
MA60:=MA(CLOSE,60);
ZJ:=(C+C+L+H)/4;
ZJ5:=MA(ZJ,5);
VAR1:=ZJ5/MA(C,20);
VAR2:=ZJ5/MA(C,50);
B:=MA(C,10)>=REF(MA(C,10),1);
后援:=IF(VAR2>1,1,VAR2);
多方:=EMA(WINNER(C)*70,2);
空方:=EMA((WINNER(C*1.1)-WINNER(C*0.9))*70,2);
捕捉:=多方>空方 AND 后援=1 AND B AND COUNT(多方>空方 AND 后援=1 AND B,5)=1;
TJJ:=MA5>MA10 AND MA10>MA20 AND EVERY(MA5>MA10,3) AND EVERY(MA10>REF(MA10,1),3) AND (MA10-MA60)/MA60*100<4;
强牛:FILTER((捕捉 OR REF(捕捉,1)) AND TJJ,5);

选股公式翻译


MA5赋值:收盘价的5日简单移动平均
MA10赋值:收盘价的10日简单移动平均
MA20赋值:收盘价的20日简单移动平均
MA30赋值:收盘价的30日简单移动平均
MA60赋值:收盘价的60日简单移动平均
ZJ赋值:(收盘价+收盘价+最低价+最高价)/4
ZJ5赋值:ZJ的5日简单移动平均
VAR1赋值:ZJ5/收盘价的20日简单移动平均
VAR2赋值:ZJ5/收盘价的50日简单移动平均
B赋值:收盘价的10日简单移动平均>=1日前的收盘价的10日简单移动平均
后援赋值:如果VAR2>1,返回1,否则返回VAR2
多方赋值:以收盘价计算的获利盘比例*70的2日指数移动平均
空方赋值:(以收盘价*1.1计算的获利盘比例-以收盘价*0.9计算的获利盘比例)*70的2日指数移动平均
捕捉赋值:多方>空方 AND 后援=1 AND B AND 统计5日中满足多方>空方AND后援=1ANDB的天数=1
TJJ赋值:MA5>MA10 AND MA10>MA20 AND 最近3日一直存在MA5>MA10 AND 最近3日一直存在MA10>1日前的MA10 AND (MA10-MA60)/MA60*100<4
输出强牛:(捕捉ORREF(捕捉,1))ANDTJJ的5日过滤