当前位置: 主页 > 股票学习 >

猛虎抓龙选股公式

: 时间:2021-02-23 14:50

选股公式源码


昨收:=REF(C,1);
涨停:=IF(((((C - 昨收) * 100) /昨收) >= (10 - ((0.01 * 100) / 昨收))),1,0);
VAR4:=EMA(CLOSE,9);
A线:=(MA(CLOSE,25) + ((MA(CLOSE,25) * 20) / 100));
B线:=(MA(CLOSE,25) + ((MA(CLOSE,25) * 6) / 100));
C线:=((((MA(CLOSE,3) + MA(CLOSE,6)) + MA(CLOSE,12)) + MA(CLOSE,24)) / 4);
D线:=EMA((VAR4 * 1.14),5);
E线:=(LLV(REF(LOW,1),2) + ((HHV(REF(HIGH,1),2) - LLV(REF(LOW,1),2)) / 2));
QD:=(((C > B线) AND (C > C线)) AND (C > E线));
幼虎:=((COUNT(QD,10) = 1) AND QD);
XYJJ:=BARSLAST(幼虎);
JS:=CROSS(C,D线);
老虎:=((COUNT(JS,XYJJ) <= 1) AND JS);
HX1:=((REF(老虎,1) AND (O > D线)) AND (C > D线));
HX2:=((REF(老虎,1) AND CROSS(C,A线)) AND (C >D线));
老虎前世:=(幼虎 AND 老虎);
老虎金身:=(HX1 OR HX2);
虎王2:=((((REF(涨停,1) AND (O >D线)) AND (O > REF(H,1))) AND (REF(H,1) < REF(D线,1))) AND (L >=D线));
猛虎:((老虎前世 OR 老虎金身) OR 虎王2);

选股公式翻译


昨收赋值:1日前的收盘价
涨停赋值:如果((((收盘价-昨收)*100)/昨收)>=(10-((0.01*100)/昨收))),返回1,否则返回0
VAR4赋值:收盘价的9日指数移动平均
A线赋值:(收盘价的25日简单移动平均 + ((收盘价的25日简单移动平均 * 20) / 100))
B线赋值:(收盘价的25日简单移动平均 + ((收盘价的25日简单移动平均 * 6) / 100))
C线赋值:((((收盘价的3日简单移动平均 + 收盘价的6日简单移动平均) + 收盘价的12日简单移动平均) + 收盘价的24日简单移动平均) / 4)
D线赋值:(VAR4*1.14)的5日指数移动平均
E线赋值:(2日内1日前的最低价的最低值 + ((2日内1日前的最高价的最高值 - 2日内1日前的最低价的最低值) / 2))
QD赋值:(((收盘价 > B线) AND (收盘价 > C线)) AND (收盘价 > E线))
幼虎赋值:((统计10日中满足QD的天数 = 1) AND QD)
XYJJ赋值:上次幼虎距今天数
JS赋值:收盘价上穿D线
老虎赋值:((统计XYJJ日中满足JS的天数 <= 1) AND JS)
HX1赋值:((1日前的老虎 AND (开盘价 > D线)) AND (收盘价 > D线))
HX2赋值:((1日前的老虎 AND 收盘价上穿A线) AND (收盘价 >D线))
老虎前世赋值:(幼虎 AND 老虎)
老虎金身赋值:(HX1 OR HX2)
虎王2赋值:((((1日前的涨停 AND (开盘价 >D线)) AND (开盘价 > 1日前的最高价)) AND (1日前的最高价 < 1日前的D线)) AND (最低价 >=D线))
输出猛虎:((老虎前世 OR 老虎金身) OR 虎王2)