当前位置: 主页 > K线图 >

涨停卧底选股公式

: 时间:2021-02-21 07:49

选股公式源码


A1:=((MA(C,60)-L)/MA(C,20))*200;
B1:=((MA(C,60)-L)/MA(C,60))*200;
C1:=((MA(C,30)-L)/MA(C,60))*200;
M1:=REF(CLOSE,1);
M2:=SMA(MAX(CLOSE-M1,0),7,1)/SMA(ABS(CLOSE-M1),7,1)*100;
G1:=FILTER(REF(M2,1)<20 AND M2>REF(M2,1),5);
TU:=C/MA(C,40)<0.74;
PER1:=5;
MMA:=EMA(C,PER1);
SMMA:=EMA(MMA,PER1);
IMPETMMA:=MMA - REF(MMA,1);
IMPETSMMA:=SMMA - REF(SMMA,1);
DIVMA:= ABS(MMA - SMMA);
TDJ:=(H-L)/REF(C,1)>0.05;
AVERIMPET:= (IMPETMMA+IMPETSMMA)/2;
TDF:= POW(DIVMA,1)*POW(AVERIMPET,3);
NTDF:=TDF/HHV(ABS(TDF),PER1*3);
YUL:=COUNT(TDJ,5)>1;
启动:=TU AND TDJ AND YUL;
确定:=CROSS(NTDF,-0.9);
波段:=FILTER((G1 AND C1>20 OR C>REF(C,1)) AND REF(启动,1),10);
选股:=FILTER(REF(启动,1) AND (确定 OR C>REF(C,1)) AND MACD.macd>-1.5,10);
卧底:COUNT(选股,13)>=1 AND 波段;

选股公式翻译


A1赋值:((收盘价的60日简单移动平均-最低价)/收盘价的20日简单移动平均)*200
B1赋值:((收盘价的60日简单移动平均-最低价)/收盘价的60日简单移动平均)*200
C1赋值:((收盘价的30日简单移动平均-最低价)/收盘价的60日简单移动平均)*200
M1赋值:1日前的收盘价
M2赋值:收盘价-M1和0的较大值的7日[1日权重]移动平均/收盘价-M1的绝对值的7日[1日权重]移动平均*100
G1赋值:1日前的M2<20ANDM2>1日前的M2的5日过滤
TU赋值:收盘价/收盘价的40日简单移动平均<0.74
PER1赋值:5
MMA赋值:收盘价的PER1日指数移动平均
SMMA赋值:MMA的PER1日指数移动平均
IMPETMMA赋值:MMA - 1日前的MMA
IMPETSMMA赋值:SMMA - 1日前的SMMA
DIVMA赋值: MMA-SMMA的绝对值
TDJ赋值:(最高价-最低价)/1日前的收盘价>0.05
AVERIMPET赋值: (IMPETMMA+IMPETSMMA)/2
TDF赋值: DIVMA的1乘幂*AVERIMPET的3乘幂
NTDF赋值:TDF/PER1*3日内TDF的绝对值的最高值
YUL赋值:统计5日中满足TDJ的天数>1
启动赋值:TU AND TDJ AND YUL
确定赋值:NTDF上穿-0.9
波段赋值:(G1ANDC1>20ORC>1日前的收盘价)ANDREF(启动,1)的10日过滤
选股赋值:1日前的启动AND(确定ORC>1日前的收盘价)ANDMACD.平滑异同平均>-1.5的10日过滤
输出卧底:统计13日中满足选股的天数>=1 AND 波段